Back to overview
Degraded

Duty System Unavailable

Dec 30, 2025 at 7:11pm UTC
Affected services
Roblox

Resolved
Dec 31, 2025 at 5:44am UTC

The duty system has been fixed.

Updated
Dec 30, 2025 at 11:37pm UTC

We have found a fix, however theres still some testing to do and our team is exhausted so please bear with us until tomorrow!

Updated
Dec 30, 2025 at 9:37pm UTC

Our team is still working on the issue. We are sorry for any inconvenience caused by the bug!

Created
Dec 30, 2025 at 7:11pm UTC

There's a major bug ingame thats forcing people to be either onduty or offduty. We are looking into this, but please bear with us!