Back to overview
Downtime
RankGun Unavailable
Nov 9, 2025 at 8:12am UTC
Affected services
RankGun
Resolved
Nov 9, 2025 at 8:22am UTC
RankGun is back!
Affected services
Created
Nov 9, 2025 at 8:12am UTC
The app/rank centre are down because of our Roblox cloud ranking thing expiring. it will be up as soon as fish wakes up.
Affected services