Back to overview
Downtime
BloxNBot ranking is unavailable
Oct 23, 2025 at 4:29pm UTC
Affected services
BloxNBot
RankGun
Resolved
Dec 17, 2025 at 9:31pm UTC
BloxNBot is back!
Affected services
Created
Oct 23, 2025 at 4:29pm UTC
Our BloxNBot ranking provider cutely banned us (we forgot to pay), so management must submit promotion requests until further notice. Apologies!
Affected services