Back to overview
Degraded
Roblox API down
Oct 20, 2025 at 9:24am UTC
Affected services
BloxNBot
Roblox
JSM
Resolved
Oct 20, 2025 at 9:37am UTC
AWS has reported that they have resolved the issue and are currently monitoring the fix.
Affected services
Created
Oct 20, 2025 at 9:24am UTC
Due to Amazon Web Services being down, Roblox API is experiencing downtime. This affects multiple systems in-game and the game and group stats for BloxNBot.
Affected services